PolicyKit is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes: It is a framework for centralizing the decision making process with respect to granting access to privileged operations for unprivileged applications. PolicyKit is specifically targeting applications in rich desktop environments on multi-user UNIX-like operating systems. It does not imply or rely on any exotic kernel features.
13 lines
674 B
Text
13 lines
674 B
Text
$NetBSD: patch-ae,v 1.1.1.1 2008/11/22 03:33:38 jmcneill Exp $
|
|
|
|
--- tools/Makefile.in.orig 2008-07-22 12:15:08.000000000 -0400
|
|
+++ tools/Makefile.in
|
|
@@ -292,7 +292,7 @@ polkit_auth_SOURCES = polkit-auth.c
|
|
polkit_auth_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ $(top_builddir)/src/polkit/libpolkit.la $(top_builddir)/src/polkit-grant/libpolkit-grant.la $(top_builddir)/src/polkit-dbus/libpolkit-dbus.la
|
|
polkit_action_SOURCES = polkit-action.c
|
|
polkit_action_LDADD = $(top_builddir)/src/polkit/libpolkit.la
|
|
-profiledir = $(sysconfdir)/profile.d
|
|
+profiledir = $(PREFIX)/share/examples/policykit
|
|
profile_SCRIPTS = polkit-bash-completion.sh
|
|
EXTRA_DIST = $(profile_SCRIPTS)
|
|
all: all-am
|